HTTP 500 - Internal server error

Aici puteţi posta întrebari legate de instalare şi configurare PHP, Apache, IIS, MySQL, PostgreSQL, Oracle, SQL Server sau altele.

Moderator: Moderatori

tepes
Average Member
Mesaje: 58
Membru din: Joi Apr 03, 2003 9:53 pm
Contact:

HTTP 500 - Internal server error

Mesajde tepes » Vin Apr 18, 2003 12:41 pm

An instalat PHP-ul si am configurat IIS pe SAPI (php4isapi.dll).
Cand accesez http://localhost, imi returneaza

HTTP 500 - Internal server error


Am instalat si pe CGI (php.exe) si cand accesez http://localhost, imi returneaza

Security Alert! The PHP CGI cannot be accessed directly.
This PHP CGI binary was compiled with force-cgi-redirect enabled. This means that a page will only be served up if the REDIRECT_STATUS CGI variable is set, e.g. via an Apache Action directive.

For more information as to why this behaviour exists, see the manual page for CGI security.

For more information about changing this behaviour or re-enabling this webserver, consult the installation file that came with this distribution, or visit the manual page.

Ce e de facut?



Avatar utilizator
ovi2ut
PHPRomania Coder Professional
Mesaje: 166
Membru din: Vin Sep 13, 2002 5:23 pm
Localitate: Middle of Nowhere
Contact:

Mesajde ovi2ut » Mie Mai 14, 2003 2:12 pm

Pentru a putea rula pe IIS (si numai in cazul asta) ca cgi trebuie sa decomentezi linia cgi.force_redirect = 1 si sa-i atribui valoarea 0.

Avatar utilizator
ovi2ut
PHPRomania Coder Professional
Mesaje: 166
Membru din: Vin Sep 13, 2002 5:23 pm
Localitate: Middle of Nowhere
Contact:

Mesajde ovi2ut » Mie Mai 14, 2003 4:43 pm

Scuze, am uitat sa scriu din ce fisier, deci din php.ini.

Avatar utilizator
biban
Senior Member
Mesaje: 204
Membru din: Dum Apr 13, 2003 8:23 pm
Localitate: Giurgiu
Contact:

Completare la ce a spus ovi

Mesajde biban » Mie Mai 14, 2003 6:25 pm

cgi.force_redirect = 1
este doar pentru apache.
pe orice alt server trebuie dezactivata aceasta linie din php.ini.

Avatar utilizator
biban
Senior Member
Mesaje: 204
Membru din: Dum Apr 13, 2003 8:23 pm
Localitate: Giurgiu
Contact:

completare la ce am spus eu

Mesajde biban » Joi Mai 15, 2003 9:36 am

...adica sa nu ma intelegi gresit:nu trebuie dezactivat punand ";" trebuie dat val 0 (disable) - asa cum a spus ovi pe IIS.

pentru info suplimentar vezi in sectiunea

Installed as CGI binary-Possible attacks

din helpu de la php
sau in fishierul install.txt din folderul ph


Înapoi la “Instalare”

Cine este conectat

Utilizatori ce ce navighează pe acest forum: Niciun utilizator înregistrat și 5 vizitatori